-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathArranging_num_in_arr.txt
57 lines (47 loc) · 1.49 KB
/
Arranging_num_in_arr.txt
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
Arrange Numbers In Array
Send Feedback
You have been given an empty array(ARR) and its size N. The only input taken from the user will be N and you need not worry about the array.
Your task is to populate the array using the integer values in the range 1 to N(both inclusive) in the order - 1,3,.......4,2.
Note:
You need not print the array. You only need to populate it.
Input Format :
The first line contains an Integer 't' which denotes the number of test cases or queries to be run. Then the test cases follow.
The first and the only line of each test case or query contains an integer 'N'.
Output Format :
For each test case, print the elements of the arra/listy separated by a single space.
Output for every test case will be printed in a separate line.
Constraints :
1 <= t <= 10^2
0 <= N <= 10^4
Time Limit: 1sec
Sample Input 1 :
1
6
Sample Output 1 :
1 3 5 6 4 2
Sample Input 2 :
1
9
Sample Output 2 :
1 3 5 7 9 8 6 4 2
import java.util.Scanner;
public class Solution {
public static void arrange(int[] arr, int n) {
//Your code goes here
Scanner s = new Scanner(System.in);
int start = 0;
int end = arr.length -1;
int x = 1;
for(int i=0; i<arr.length; i++){
if(i%2==0){
arr[start]=x;
start++;
x++;
}else {
arr[end]=x;
end--;
x++;
}
}
}
}