-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathChar_pattern3.txt
74 lines (61 loc) · 1.13 KB
/
Char_pattern3.txt
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
Code : Interesting Alphabets
Send Feedback
Print the following pattern for the given number of rows.
Pattern for N = 5
E
DE
CDE
BCDE
ABCDE
Input format :
N (Total no. of rows)
Output format :
Pattern in N lines
Constraints
0 <= N <= 26
Sample Input 1:
8
Sample Output 1:
H
GH
FGH
EFGH
DEFGH
CDEFGH
BCDEFGH
ABCDEFGH
Sample Input 2:
7
Sample Output 2:
G
FG
EFG
DEFG
CDEFG
BCDEFG
ABCDEFG
import java.util.Scanner;
public class Solution {
public static void main(String[] args) {
/* Your class should be named Solution.
* Read input as specified in the question.
* Print output as specified in the question.
*/
Scanner s = new Scanner(System.in);
int n = s.nextInt();
int i =1;
int x =n;
while(i<=n){
char ch = (char)('A'+x-1);
int j =1;
while(j<=i){
System.out.print(ch);
ch = (char)(ch + 1);
j=j+1;
}
System.out.print("\n");
i=i+1;
x = x-1;
}
}
}